the readme sucked balls anyway.
@previous (r04r)
What do I need to do?
I tried using ATBBS2, and errors are gone once I enabled the rewrite_module in Apache, but I still can't post any topics without getting two session errors. (And with TinyBBS it just makes it 404)
(Edited 41 seconds later.)
@139,590 (A)
You need the rewrite module, should work after that.
@previous (A)
Try disabling the gzip code in the htaccess. If that doesn't work, pastebin it.
@previous (A)
Yes.
Also disable the GZIP toggle in config.php
(Edited 17 seconds later.)
@previous (A)
<ifModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/plain text/xml application/x-javascript
</ifModule>
<ifModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>
<IfModule mod_expires.c>
ExpiresActive on
ExpiresByType image/jpg "access 1 month"
ExpiresByType image/jpeg "access 1 month"
ExpiresByType image/gif "access 1 month"
ExpiresByType image/png "access 1 month"
ExpiresByType text/html "access 1 day"
ExpiresByType text/javascript "access 1 month"
ExpiresByType application/x-javascript "access 1 month"
ExpiresByType text/css "access 1 month"
ExpiresDefault "access 2 days"
</IfModule>
<ifModule mod_headers.c>
<FilesMatch "\\.(ico|pdf|flv|jpg|jpeg|png|gif|swf)$">
Header set Cache-Control "max-age=2592000, public"
</FilesMatch>
<FilesMatch "\\.(css)$">
Header set Cache-Control "max-age=604800, public"
Header set Vary "accept-encoding"
</FilesMatch>
<FilesMatch "\\.(js)$">
Header set Cache-Control "max-age=216000, private"
</FilesMatch>
<FilesMatch "\\.(xml|txt)$">
Header set Cache-Control "max-age=216000, public, must-revalidate"
</FilesMatch>
<FilesMatch "\\.(html|htm|php)$">
Header set Cache-Control "max-age=1, private, must-revalidate"
</FilesMatch>
</ifModule>
^Remove that. If it then works add them in one by one to see which one is borked for you.
@139,613 (r04r)
That worked, but now I get this
@previous (r04r)
setting mod_gzip to false in config.php fixed it.
(Edited 1 minute later.)
@139,614 (A)
Ah. The toggle in PHP should be off if your web server supports gzip. Someone fucked with the default config.php I guess, idk.
@previous (r04r)
I think I got this tinybbs from Eels. That's fixed now, but this error is present on every page (excluding /watchlist). I don't understand what it is going wrong.
@previous (A)
Your PHP is in nazi mode (default config in wamp). Google on how to turn error reporting down to just show critical errors/errors/warnings.
@previous (r04r)
Everything works! I love you.
I was trying to put it all into C:\wamp\www but I wanted to keep the default index.php with wamp, so I created a new folder at C:\www\ and set up an alias, which I called it "stuff". Now every time I go to 127.0.0.1/stuff it says "The requested URL /www/index.php was not found on this server." It works fine if I put a normal text file or index file in there, but as soon as I copy all the chan files to the folder it gives the "not found" error. I've set up the alias correctly.
Fuck.
@139,590 (A)
Then just use ATBBS2 you mora.
@previous (Possibly !4et0YaTXO.)
Read what I said again; I can't. It just returns session errors, my problem is solved anyway you mora.
Also:
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
Yea... no thanks.