Minichan

Topic: Trying to install TinyBBS on localhost

Anonymous A started this discussion 15 years ago #8,027

I've edited config.php, and I've imported INSTALL.sql. I'm just getting internal server errors, I don't know why.

I'm trying to install at C:\Wamp\www\test - so in config.php I've set the domain as http://localhost/test/. Is that right?

Who removed the damn readme files. :X

Anonymous B joined in and replied with this 15 years ago, 10 minutes later[^] [v] #139,579

the readme sucked balls anyway.

Anonymous C joined in and replied with this 15 years ago, 5 minutes later, 15 minutes after the original post[^] [v] #139,580

Image went missing> wamp

Anonymous A (OP) replied with this 15 years ago, 4 minutes later, 20 minutes after the original post[^] [v] #139,581

I'm just getting Internal Server Error. I'm sure I've done everything correctly.

r04r joined in and replied with this 15 years ago, 2 hours later, 3 hours after the original post[^] [v] #139,588

Htaccess

Anonymous A (OP) replied with this 15 years ago, 6 minutes later, 3 hours after the original post[^] [v] #139,590

Image went missing@previous (r04r)
What do I need to do?

I tried using ATBBS2, and errors are gone once I enabled the rewrite_module in Apache, but I still can't post any topics without getting two session errors. (And with TinyBBS it just makes it 404)

(Edited 41 seconds later.)

Anonymous C replied with this 15 years ago, 14 seconds later, 3 hours after the original post[^] [v] #139,591

@139,588 (r04r)

Anonymous B replied with this 15 years ago, 4 minutes later, 3 hours after the original post[^] [v] #139,592

@139,590 (A)
lol, ATBBS2.

r04r replied with this 15 years ago, 46 minutes later, 4 hours after the original post[^] [v] #139,606

@139,590 (A)
You need the rewrite module, should work after that.

Anonymous A (OP) replied with this 15 years ago, 15 minutes later, 4 hours after the original post[^] [v] #139,610

Image went missing@previous (r04r)
Now I'm getting this.

:s

r04r replied with this 15 years ago, 1 minute later, 4 hours after the original post[^] [v] #139,611

@previous (A)
Try disabling the gzip code in the htaccess. If that doesn't work, pastebin it.

Anonymous A (OP) replied with this 15 years ago, 4 minutes later, 4 hours after the original post[^] [v] #139,612

@previous (r04r)
Nope, still not working.
> If that doesn't work, pastebin it.
The htaccess file?

r04r replied with this 15 years ago, 40 seconds later, 4 hours after the original post[^] [v] #139,613

@previous (A)
Yes.

Also disable the GZIP toggle in config.php

(Edited 17 seconds later.)

Anonymous A (OP) replied with this 15 years ago, 3 minutes later, 4 hours after the original post[^] [v] #139,614

that fixed it

(Edited 1 minute later.)

r04r replied with this 15 years ago, 1 minute later, 4 hours after the original post[^] [v] #139,615

@previous (A)
<ifModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/plain text/xml application/x-javascript
</ifModule>

<ifModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>
<IfModule mod_expires.c>
ExpiresActive on
ExpiresByType image/jpg "access 1 month"
ExpiresByType image/jpeg "access 1 month"
ExpiresByType image/gif "access 1 month"
ExpiresByType image/png "access 1 month"
ExpiresByType text/html "access 1 day"
ExpiresByType text/javascript "access 1 month"
ExpiresByType application/x-javascript "access 1 month"
ExpiresByType text/css "access 1 month"
ExpiresDefault "access 2 days"
</IfModule>

<ifModule mod_headers.c>
<FilesMatch "\\.(ico|pdf|flv|jpg|jpeg|png|gif|swf)$">
Header set Cache-Control "max-age=2592000, public"
</FilesMatch>
<FilesMatch "\\.(css)$">
Header set Cache-Control "max-age=604800, public"
Header set Vary "accept-encoding"
</FilesMatch>
<FilesMatch "\\.(js)$">
Header set Cache-Control "max-age=216000, private"
</FilesMatch>
<FilesMatch "\\.(xml|txt)$">
Header set Cache-Control "max-age=216000, public, must-revalidate"
</FilesMatch>
<FilesMatch "\\.(html|htm|php)$">
Header set Cache-Control "max-age=1, private, must-revalidate"
</FilesMatch>
</ifModule>

^Remove that. If it then works add them in one by one to see which one is borked for you.

Anonymous A (OP) replied with this 15 years ago, 19 seconds later, 4 hours after the original post[^] [v] #139,616

Image went missing@139,613 (r04r)
That worked, but now I get this

@previous (r04r)
setting mod_gzip to false in config.php fixed it.

(Edited 1 minute later.)

r04r replied with this 15 years ago, 26 seconds later, 4 hours after the original post[^] [v] #139,617

@139,614 (A)
Ah. The toggle in PHP should be off if your web server supports gzip. Someone fucked with the default config.php I guess, idk.

Anonymous A (OP) replied with this 15 years ago, 6 minutes later, 4 hours after the original post[^] [v] #139,618

Image went missing@previous (r04r)
I think I got this tinybbs from Eels. That's fixed now, but this error is present on every page (excluding /watchlist). I don't understand what it is going wrong.

r04r replied with this 15 years ago, 55 seconds later, 4 hours after the original post[^] [v] #139,619

@previous (A)
Your PHP is in nazi mode (default config in wamp). Google on how to turn error reporting down to just show critical errors/errors/warnings.

Anonymous A (OP) replied with this 15 years ago, 22 minutes later, 4 hours after the original post[^] [v] #139,620

@previous (r04r)
Everything works! I love you.

Anonymous A (OP) double-posted this 15 years ago, 57 minutes later, 5 hours after the original post[^] [v] #139,627

I was trying to put it all into C:\wamp\www but I wanted to keep the default index.php with wamp, so I created a new folder at C:\www\ and set up an alias, which I called it "stuff". Now every time I go to 127.0.0.1/stuff it says "The requested URL /www/index.php was not found on this server." It works fine if I put a normal text file or index file in there, but as soon as I copy all the chan files to the folder it gives the "not found" error. I've set up the alias correctly.

Fuck.

Possibly !4et0YaTXO. joined in and replied with this 15 years ago, 12 minutes later, 6 hours after the original post[^] [v] #139,631

@139,590 (A)
Then just use ATBBS2 you mora.

Anonymous A (OP) replied with this 15 years ago, 9 minutes later, 6 hours after the original post[^] [v] #139,632

@previous (Possibly !4et0YaTXO.)
Read what I said again; I can't. It just returns session errors, my problem is solved anyway you mora.
Also:
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
> session error
Yea... no thanks.

dreamworks joined in and replied with this 15 years ago, 2 minutes later, 6 hours after the original post[^] [v] #139,633

@139,631 (Possibly !4et0YaTXO.)
> DM
> talking about websites
:

Please familiarise yourself with the rules and markup syntax before posting.